Paused activation of Jira connector sprint assignment logic

Update: This feature has been re-enabled with the 11.12.0 release

On Wednesday, March 26, 2025, we identified an issue with the recently reintroduced Jira connector sprint sync logic, and deactivated the enhancement in both sandbox and production environments.

We expect to reactivate the sync logic in a future release, after adding changes that will prevent this issue. We’ll update this announcement and our release notes once a new version is identified.

Note: On-premise environments are not affected, as the activation of the logic was not included in upcoming version 11.9.1.

Review this announcement to understand if you may be affected, and the actions you can take to correct sprint assignments in Jira Align.

Why we’re pausing

In some cases, stories or defects in Jira Align can be incorrectly moved to the unassigned backlog after closing a sprint in Jira. The unexpected behavior only occurs when syncing from Jira to Jira Align; data in Jira is not affected.

Conditions that caused unintended changes

This issue only occurred when the following configurations were set and actions were taken inside of Jira:

  1. The connected Jira environment used a workflow configuration that set work items with a “done” Status that did not have a status category of Done.
  2. The sprint was then closed.

Root cause

When a sprint was closed in Jira, the connector searched for any open stories or defects in the sprint and moved them to the unassigned backlog. The connector was incorrectly identifying stories that appeared to be open, based on the Jira status category. Some Jira workflows may use a status to indicate completeness that isn’t assigned to the Done status category. When using such statuses, the workflow configuration usually writes entries to the Resolution and/or Resolution Date fields.

Actions you can take

For most Jira workflows, sprint assignments in Jira Align were not affected. If you use a status in Jira that belongs to the Done status category, no action is required.

If you use a “done”, “complete”, etc status in Jira that does not belong to the Done status category, the connector may have moved matching work items to the unassigned backlog in Jira Align. If you’ve set up your workflow in such a manner, you can search for affected items inside Jira Align by using Jira query language (JQL):

  1. Navigate to the Jira integration tab inside Jira settings.
  2. Enter the following JQL query:
    "issuetype IN ([insert issue type(s) here]) AND statusCategory != Done AND sprint = ([ID of sprint that was closed]) AND NOT IN (futureSprints())"

Once you’ve identified the items in Jira that meet this criteria, you can move them in Jira Align back to the correct sprint.

Actions we’re taking

We plan to correct this unexpected behavior by adding additional checks to the Jira connector’s sprint sync logic after closing a sprint:

  • If Jira Status Category != Done, check additional fields for data.
    • If both Resolution and Resolution Date fields are empty, move the work item to the unassigned backlog in Jira Align.
    • If either Resolution or Resolution Date fields contain entries, do not move the work item in Jira Align.

We’ll provide updates once a new version is identified for reactivating the feature with these changes.

Was this article helpful?
0 out of 0 found this helpful
Print Friendly Version of this pagePrint Get a PDF version of this webpagePDF

Join the Atlassian Community!

The Atlassian Community is a unique, highly collaborative space where customers and Atlassians come together. Ask questions and get answers, start discussions, and collaborate with thousands of other Jira Align customers. Visit the Jira Align Community Collection today.

Need to contact Jira Align Support? Please open a support request.